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1.

2.

3.

4.

5.

6.

Configure the parameters as shown in the screen above.

With the project created, recognize the modules:

Online > Connect;

 Set the PLC to STOP;

Online > Diagnosis > I/O Information...;

 Click on “I/O Sync” and confirm with “OK”;

 Double-click on NewPLC [B0S1 XBL-EMTA];

 The following screen will open:
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01- PLC 01 SLAVE CONFIGURATION:

Ethernet TCP/IP COMMUNICATION BETWEEN 4 PLC’S:

APPLICATIONS



 

7. Click on Modbus Settings:
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Configure the parameters as shown in the screen above. This means that the information made

available by the Slave PLC for reading must be placed in the D0 memory of the Slave PLC. When the

Master PLC requests reading, the data in the D0 memory of the Slave PLC will be transferred to a

memory in the Master PLC. When the Master PLC writes some data to the Slave PLC, this data will

appear in the D10 memory of the Slave PLC.



8. 

9. Click on Online > Write…;
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For the other PLCs, the previous steps must be repeated, changing only the Station Number and
IP address for each PLC, as shown in the screen below:



1.

2.

3.

4.

5.

 

With the project created, recognize the modules: Online >

Connect; Put the PLC in STOP; Online > Diagnosis > I/O

Information...; Click on “I/O Sync” and confirm with “OK”; Double

click on NewPLC [B0S1 XBL-EMTA];
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02- MASTER PLC CONFIGURATION:



1- 

 

Configure the data as shown in the screen below:
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Remember that the IP range of all PLCs must be the same. In this example, our Master PLC ended
in 5.

The “No of Dedicated Connection” needs to be set to 1 for 3 slave communication.



2- 

 

3- Select the Slot and confirm with “OK”;

Right-click NewPLC [B0S1 XBL-EMTA] > Add Item > P2P Communication:
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4- 

 

Click 2 vezes em P2P Channel: 
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5- Configure as shown in the screen below, placing the IP addresses previously configured on the
Slaves:



6- 
 

Click 2 vezes em P2P Block: 

 

7- Now we will configure all the READ addresses of the Master PLC:
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Ch / Driver Settings – Configured in step 5; 

P2P – Configured for data reading; 

Conditional Flag – Every time memories M100, M101, M102 go to high logic level 

the Master PLC performs the reading; 

Data Size – Space reserved for data, i.e., 10 words; 

Destination Station Number – Configured in step 8 of item 01 - PLC 01 
Slave Configuration;



- D0 to D9 – Receiving Data from Slave 1’s D0 Memory; - D10 to D19 –

Receiving Data from Slave 2’s D0 Memory; - D20 to D29 – Receiving

Data from Slave 3’s D0 Memory;

9- Now we will configure all the WRITE addresses of the Master PLC:
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8- Click on settings and configure the reading memories. In this example, we configured
the memories: D0, D10 and D20. This means that these memories are the ones that will
receive data stored in the D0 memory of the Slave PLCs.



- D30– Sending Data to Memory D10 of Slave 1; - D40–

Sending Data to Memory D10 of Slave 2; - D50– Sending

Data to Memory D10 of Slave 3;
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10- Click on settings and configure the writing memories. In this example we configured
the memories: D30, D40 and D50. This means that these memories are the memories that
will send the data to the D10 memory of the Slave PLCs.



Transfer this program to the Master PLC;

 

11- Click em Online > Write; 

12- Click em Online > Communication Module Setting > Enable Link (HS Link, P2P); 

13- Select the option P2P 02 [B0S1 XBL-EMTA] e click em Write > Ok > Close: 
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14- automatic recall of “Condition Flags” memories: automatic recall of “Condition Flags”
memories:
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15- 15- To perform a test, open two XG5000, one with the Master's program and the other
with the program of one of the Slaves; 

16. In the Master PLC program, click on Monitor > Device Monitoring and select D;

17. In the Slave PLC program, click on Monitor > Device Monitoring and select D;

18. In the Master PLC’s Device Monitoring, enter a value in memory D30, D40, or D50. This value will

be read by the Slave and will appear in memory D10 of the respective slave.

19- In one of the slaves, enter a value in memory D0 and this value will be read by the

Master and will appear in one of the memories D0, D10 or D20 depending on the slave.

 

In the example above, the value 50 was written to the D50 memory of the Master PLC and this value
was read (transferred) by the D10 memory of Slave 3. The value 10 was also written to the D0 memory
of Slave 3 and this value was read (transferred) by the D50 memory of the Master.

END.



- On the XG5000: 1. Click on Tools > Network Manager to

open XG-PD; 2. New > Choose a name > Choose the PLC

model; 3. Click on Online > Conect; 4. Click on Online > Read

IO Information; 5. Double-click on FEnet;
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Ethernet COMMUNICATION: PLC XGB / XBL EMTA



 

6. 
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Configure the parameters that will be used for the XBL-EMTA module, as shown in the
screen below and click OK:



 

7- Click on P2P(EIP) at the bottom left of the screen;

 

8- Double-click on P2P 03 and select FEnet and the slot where the module is located, in

this case

example, slot 6. Click OK:
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10 – Right click on User frame definition > Add Group:

 

9- Double click on P2P Chanel and configure the parameters as shown in the screen below:
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13 – Set the parameters as shown in the screen below and click OK:

 

12 – Right-click on [Transmission] Counter and select Add Frame:
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11- Preencha o Group name e selecione em Frame type: Transmission, pois nesse caso queremos 
enviar dados do CLP para o Computador via Ethernet: 



02: STX in Hexadecimal;

15- Configure the Parameters as shown in the screen below:

 

14- Right click on the white screen on the right and select Add Segment:
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17 – Set the parameters as shown in the screen below and click OK:

 

18- Right click on the white screen on the right and select Add Segment:
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16 – Right-click on Counter [Transmission] again and select Add Frame:



 

19- Configure os Parâmetros conforme a tela abaixo: 
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03: ETX em Hexadecimal; 

20 – Click novamente com o botão direito em Contador [Transmission] selecione Add Frame: 



 

23- Configure the Parameters as shown in the screen below:

 

21 – Set the parameters as shown in the screen below and click OK

 

22- Right click on the white screen on the right and select Add Segment:
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Click on setting and configure as shown in the screen below:

 

24- Double-click on P2P Block and configure the parameters as shown in the screen below:
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In this example, we have placed the D0 memory in the Read area. This means that the data

contained in the D0 memory will be read and sent via Ethernet to the destination computer.



 

26- Click em Online > Enable Link: 

 

25. Click Online > Write Parameter and then OK:
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27- As the configuration was done in P2P03, check this option to be enabled and then
click on Write > OK > Close:
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28- We can perform a test using a program for Ethernet communication, in this example we use the
Hercules Software to read the data sent from the PLC to the Computer. Configure according to the
screen below and click on Listen:
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29- When memory M57 goes to 1, as previously configured, the data in memory D0 will be sent to
the Hercules software as shown in the figure below:

And



1. In XP-Builder right click on Script > Insert:
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Creating a Script for HMI



2. 

3. Return to screen B-1:

Enter the code as shown in the screen below;
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4. On the main screen B-1, create a Bit Switch named M0 like the image below:
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5. Right-click on the screen and then click on Screen Property:
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6. Click on Etc. and then on Add & Modify:
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7.

8.

9.

Select the Script created in Script Name; In

Execution Condition, select Consecutive; Click on

Insert;

10. Click OK and then OK again; 

11. Transfer the program to the HMI;

 12.

Now, every time M0 goes to logic level 1, the Beep function will be activated.
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Syntax for memories in programming:
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Device 
Status

Examples 

@[X:No: *1]

@[S:No: *1]

@[L:No: *1]

@[W:No: *1]

@[D:No: *1]

@[F:No: *1] 

Examples of Use 

X : BIT device

S : SHORT(16bit) device

L : INT (32 bit) device

W : UNSIGNED SHORT(16 bit)

D : UNSIGNED INT(32 bit)

F : FLOAT device 

@[X:0:P001], @[X:P001]

@[S:0:P000], @[S:2:#1:P000]

@[L:0:P000], @[L:P000]

@[W:0:P000], @[W:1:#3:P000]

@[D:0:P000], @[D:#1:P000]

@[F:0:P000], @[F:#1:P000] 

And. 



1- In XP-Builder, right-click on Text Table and then on Insert:
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Alarm History and POP-UP



2- We will have the following table that can be configured as shown in the image below:

The description in the second column “Alarm 01” is the message that the user will receive if
the condition of alarm 1, which we will see later, occurs.
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3- 

4- 

 

Right click on History Alarm > Insert > Alarm Group:
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We can write on the Alarm Group screen the group to which this alarm belongs, in this
case Zone 03:



5- 

6- Configure the data as shown in the screen below:

 

Then right-click on Alarm Group > Insert > Alarm List:
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HX1, HX2 and HX3 are internal memories of the HMI. If we were to use memories from the LS PLC, we

could use memories M1, M2 and M3, for example. In Alarm Condition we define when the alarm action

will occur. In this example, when any of these memories goes to a high logic level (On), an alarm warning

will be written in a table that we will create next.

7- Click on History Alarm Viewer to create the table in the Base Screen:



8- 

 

Click on the screen and drag to create the table and then click OK:
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9- Create three buttons (Bit Switch - Momentary) as HX1, HX2 and HX3 respectively on the
screen that will serve to simulate the alarms. Every time one of these buttons is pressed, it will
be recorded in the table.

10- We can also create a scroll on the screen to check all occurrences, click on Special Switch:



 

11- Create a button on the screen next to the table and in the window that will open,
select the History Alarm Viewer Line Up option within
History Alarm Viewer:
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12- After creating the button, it will look similar to the screen below:
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13- Create another button by selecting the button already created and using CTRL C to copy it
and CTRL V to paste the new button. Double-click on the second button and change it to the
History Alarm Viewer Line Down option:



14- The screen will look something like this:

15- Now we can click on simulation mode to perform a test:
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16- By pressing the buttons we notice that they are sequentially recorded in the table.

47 

To see all the alarms that have occurred, we can use the two buttons created on the right side of the
table, which have the function of scrolling the screen down or up.



 
We can also use a POP-UP function on the screen for better viewing of the alarm.

17- Creating another program just to demonstrate the POP-UP screen: 

18- Right-click on Windows and then on the Insert option:
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A screen will open so that we can configure the POP-UP design. We can right-click on the screen
and then click on the Screen Property option to change the screen color and we can also insert texts
corresponding to the alarm.

Creating POP-UP function
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19- With the POP-UP created, let's now create the Bit Windows function. We need to
create this function on the screen where we want the POP-UP to open. If you want to open
the alarm POP-UP on all screens, we can use the CTRL C and CTRL V commands to copy it to
all screens. Only the screen that contains the Bit Windows function will call the POP-UP.
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20- Go back to the base screen and click on the Bit Windows object, drag it on the base
screen to create it.

21- Configure the memory corresponding to the alarm. In this case, the HX1 memory
corresponding to alarm 01 was configured. However, it could be any memory configured for
the alarm in the PLC. Click on Browser and locate the POP-UP screen that was designed
previously.



22- To test the program, create a Bit Switch button on the screen as Alternative and memory
HX1:
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23- We can simulate the program to see the result:
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And.
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This XP-Builder function allows you to perform data or bit backups from the HMI’s internal memory or

even from the PLC’s memory. The information from the acquisitions made is first recorded in the HMI’s

internal memory and then sent to an external area, such as a CF Card, Pendrive or Email, configurable

depending on the HMI model.

DATA BACKUP CONFIGURATION

- In XP-Builder, double-click on Logging in the column on the left:

Loggin with sending of E-mail



 

Now double click on blank line 1 of the log:
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- On the first screen of the “Logging Device” logging, you must configure which memory contains the
data you want to back up.
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Logging device: you must choose whether you want to back up a bit or a word. You also choose

which memory will be copied; in this example, we chose D500 (PLC memory) and the word

option.

If Bit is selected, the memory state will be backed up, whether it is at a high or low level. If
Word is selected, the data contained in this word will be backed up.

Device count: In this option you must enter how many records you want to have in your
spreadsheet.

The logging configures a sequence of two memories at a time, for example:

If you configured the Device count to 3, it will reserve six memories for backup.

Since in this example above the memory D500 was configured, if we had left

the Device count at 3, the logging would backup the data that is stored in memories

D500, D502 and D504.

- In the next tab we have the conditions for the backup to happen.
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In Periodic logging you can configure how often the backup will be made or you can configure

a memory to activate the backup initialization. In this example we have configured memory

M6, which means that every time memory M6 goes to a high level (from 0 to 1) the data

contained in memory D500 will be copied and written to the HMI's internal memory. The

options Rising edge and Falling edge, when checked, mean that the backup will be made on

the rising edge of memory M6 or the backup will be made on the falling edge of M6,

respectively. With Repeat by and Repeat Period, you configure how many times in a given

period of time the backup will be allowed. For example, if Repeat by is set to 1 and Repeat

period in the minutes field is set to 1, as in the example above, the backup will be made once

per minute, even if the M6 ​​memory goes to a high logic level several times within this minute.

This means that only 1 backup will be allowed during the current minute. The next acquisition

will only be released in the next minute and will only be made when M6 goes to a high level

again. Remember that it recognizes the rising edge, so M6 needs to go from logic level 0 to

logic level 1 if the Rising edge option is checked.
In the Backup Area/Buffer Manage/Backup Format tab we can choose where the HMI will send

the backup data stored in its internal memory and we can also configure how the data will

appear in the spreadsheet.



57 

 

In this example, we selected the USB Memory option, which will send the backup information that

is in the HMI's internal memory to a USB flash drive. However, in order for this information to be

sent to the USB flash drive, we need to select the Backup device option and configure a memory

(bit) in the field next to it. This means that when this memory goes to a high level, the HMI starts

the transfer process to the external device. In Logging Area, we have two important options. The

HMI is configured at the factory so that after transferring the data that is in its internal memory to

an external device, the system automatically clears its internal memory for the next acquisitions.

Now, if the Do not clear log area at backup option is selected, this will not occur and when you

transfer a copy of the file containing the collected data to the external device, the original file will

remain taking up space in the HMI's internal memory.
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If the HMI's internal memory is completely occupied and the Auto backup If area full option is

checked, the HMI system will automatically make a backup to the configured external device.

If these two options are not checked and for some reason an error occurs when sending data

to the external device, this data will still be stored in the HMI's internal memory, even if it is

turned off, and can be sent to an external device at any time. In Backup Device, in the example

above, we configured memory M0, which means that when M0 goes to a high logic level, all

data in the HMI's internal memory will begin to be transferred to the flash drive. After this

data is copied, the HMI notifies the end of the copy by activating a bit. In this case, we

configured memory M1, where this memory can be an LED on the HMI screen, for example, to

show that the transfer process has been completed. The Send Email after backup done option

can be checked if you want the file with the backup data to be sent by email. Remember that

for this we also need to configure other fields, which will be shown at the end of this

procedure. � Still in Backup Device, we have a button called Settings CSV file format. Clicking

on this button, we have the following screen:
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On this screen, we can configure how the data will appear on the spreadsheet. In the Data 1
column, the first line will be the name of the column that will contain the collected data. In this
example, we call it mg/Nm³. The lines below are configured, respectively: the type of data you are
collecting, in this case float, with a maximum of 7 digits and always showing 2 decimal places after
the comma. If we had configured the Device count, on the first logging screen, other than 1, more
configurable columns like this would be shown on this screen, named as Data 1, Data 2, Data 3,
etc... and so on.

 

In the last tab we have to configure the internal memory space that we need to reserve in the HMI.

The maximum configurable memory is described in the manual of each HMI model. Remember

that when we start collecting data, the HMI first sends this data to an internal memory, in this case

we reserve approximately 100 Kbytes of internal memory.

After these configurations, just click Ok and test the application.



 

Configuration for sending email

- Still in XP-Builder, click on Common > Project Property Settings;

- Now click on the Auxiliary Settings tab and check the Use E-mail

function option;

- Click on the Server Settings button;

- Configure the e-mail data as shown in the screen below:
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- In the Mail Server tab, you must configure the SMTP sending server of the email account used
and the sending port.
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In the case of Hotmail, we need to select the Use SSL/TLS option because the Hotmail server

requires this type of authentication, but this will depend on the email server used. We also

need to select the My SMTP option and configure the username and password of the email

that will send the attached file. After these settings, just click OK and every time the system

backs up the HMI's internal memory to an external device, an email will be automatically sent

with an attached file of the collected data.

And.
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In this PLC, output P40 is responsible for the "Pulses" of the X-axis, and output P42 is

responsible for the "Direction" of the X-axis. For the Y-axis, outputs P41 are used for "Pulse"

and P43 for "Direction".

� 

The PLC used for this type of application must necessarily have transistor outputs.

WIRING DIAGRAM:

 We need to know whether the output of the PLC used is NPN or PNP. In the case of LS PLCs, all

outputs are NPN.

Positioning - Stepper Motor with PLC



 

Connection diagram: PLC – Driver – Motor:
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Configuration in XG5000:

 Click on “Embedded Parameter” > “Position”
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Resistors must be used at the CP and DIR inputs of the driver to reduce the voltage, as this drive
works with 5V at its inputs and the PLC in this case supplies 24V at its outputs.

In this example, we will enable only the X-axis to work with the IST and DST functions, which will be
explained later. In “Positioning”, change to “1: Use” to enable the X-axis, and in “Upper/Lower Limit”,
change to “0: Not Use” because in this example, we will not use maximum and minimum limit sensors.
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There are two ways to control the Stepper Motor with LS PLCs. The "Position" function can be

controlled either with the IST (Indirectly Start) function or with the DST (Directly Start) function.
PLC PROGRAMMING IN IST MODE:

 

In this mode, we have a table that can be configured to execute a sequence of steps. It is commonly

used when the stepper motor will always perform the same movements in a pre-defined sequence.

1st Column - Step - In the first column, we find the step number, which represents the steps that will

be executed according to the step configuration. The number of steps may vary depending on the PLC

used. In this example, we can see that we can perform a task with up to 30 movements on the X-axis

and 30 movements on the Y-axis when using the IST function.
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 2nd Column – Coord. - In this option, the type of coordinate is configured: Absolute (ABS) or

Incremental (INC).

3rd Column – Pattern - In this function, there are two commonly used options:

END: Executes the step in this line and stops; it does not proceed to the next one.

KEEP: Executes the step in this line and continues to the next line in sequence, and so on, until it

encounters a line set to END.

4th Column – Control - In this column, you define whether the control for this step will be based

on position or speed.

5th Column – Method - This column is used when you want to repeat the programming starting

from a specific step.

 Example: If the sequence of movements in your program ends at step 6, but you need to restart

the program and go back to the first step, making it repeat the sequence of steps 1, 2, 3, 4, 5, and

6 again. In step 6, you can configure the Method as “REP” and in the next column, configure the

step number where you want the program to go (in our case, step number 1).

6th Column – REP Step - Continuing the example above. This column specifies the step number

where you want the program to go. In our example, we want the program to perform a sequence

of 6 movements, and once the sixth movement is completed, it should restart this sequence from

the first step. Therefore, in this case, in the sixth step, we should place the number 1 in this

column, indicating the start (step 1) and end (step 6) of a loop.

7th Column – Address (pulse) - In this column, you need to define the number of pulses this line

will execute. The stepper motor will move according to the number of pulses.

 Remember that to determine the distance traveled, it depends not only on the number of pulses

but also on how many degrees the stepper motor rotates with just one pulse and the diameter of

the shaft.

8th Column – M code - Always leave it at 0.

9th Column – A/D No. - This column is responsible for the acceleration and deceleration ramp,

which is configured in the Position Parameter tab. You can configure up to 4 ramps.

10th Column – Speed (pls/s) - This column is responsible for the pulse speed (pulses per second)

sent by the PLC. In this tutorial, we are using output P40. The more pulses per second the PLC

sends to the stepper motor driver, the faster the motor will rotate, respecting the limits of both

the driver and the PLC.
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11th Column – Dwell (ms) – In this column you can set a delay time before starting to execute the next

line. For example: If the first line is set to Dwell of 500 milliseconds, the program will execute the first

line, wait half a second and then execute the second line. This is a time delay between lines. Below is

an example of 3 movements made in the IST function:

Step 1: The movement will start in incremental coordinates, moving the stepper motor 5000 pulses at a

speed of 1000 pulses per second. After completing this distance, it will wait for 3 seconds before

executing Step 2.

Step 2: The movement will continue, but now in the opposite direction, as it will go to address -5000.

Since the motor is currently at pulse 5000, it will move back -5000 pulses, returning to the origin position

(0) and without waiting any time, it will proceed to Step 3.

Step 3: In the third line, the motor will move 10000 pulses in the clockwise direction at a speed of 10000

pulses per second, wait for 2 seconds, and then go to Step 1, repeating all movements in a loop.

To activate the IST function, we place an M6 memory, where the IST function, like the other

Positioning functions, will only recognize the rising edge of this contact, so we can use the F3 or

sF1(P) contact of the XG5000.
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Depois da tabela configurada, fica muito simples utilizar a função IST. Para isso bastar apertar a tecla   
F10 do teclado e escrever IST.   Descrição dos parâmetros :   1° Parâmetro (0) - sl – O primeiro parâmetro
é responsável pelo número do SLOT. O slot 0 significa que   o driver do motor de passo está ligado direto
no CLP. Caso seja utilizado um módulo de expansão de   posicionamento conectado ao CLP, o número do
slot será o número referente a quantidade de módulos   que se encontram conectados no CLP, por
exemplo: Se você possuí um CLP e três módulos conectado a   sua lateral e o módulo de posicionamento
é o terceiro módulo, o número do slot será 3 e assim por   diante.   2° Parâmetro (0) - ax – Este
parâmetro é responsável pelo eixo que você deseja movimentar, para o eixo   X você deve entrar com o
valor “0”, caso queria comandar o eixo Y o valor do segundo parâmetro deve   ser “1”. 3° Parâmetro: (1)
(n1) – Este parâmetro é responsável pelo número do step a ser executado. O número   1 indica que o
programa vai iniciar a execução pela primeira linha. Ao acionarmos a memória M6 iniciará   o movimento
da primeira linha e caso esta primeira linha estiver configurada como KEEP ela irá terminar   o
movimento e seguir para a segunda linha e assim por diante. Lembrando que para o movimento do   
motor acontecer, precisamos antes dar um pulso na função FLT para mostrar ao programa onde é a   
origem do movimento e só depois desta ação o IST irá funcionar.



 

PLC PROGRAMMING IN DST MODE:
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K04291 – Has the JOG function in the clockwise direction, this function is normally used to make the
motor rotate when pressing a Push-Button type button and stop rotating when releasing the button. In
the HMI it can be used with a “Momentary” type button (Bit Switch):

K04292 – Has the same function as the one mentioned above, but for the counterclockwise direction.

FLT – The FLT function is used to reset the current position. When memory M2, in this example, goes to

logic level 1, the program will understand that this is the origin of the path and will send the pulse

number of the current position to zero, being ready to receive the next position (number of pulses) to

move to, considering that it is starting from pulse zero. The FLT function must receive a pulse the first

time the program is executed. It can also be used again if you want to reset the pulses of the current

position.
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DST – The first DST function we have in the program is being activated by memory M0003.

This function aims to provide the program with all the parameters necessary for the stepper

motor to start operating. You can enter fixed values ​​or memories in this function so that the

user can later enter the values ​​via the HMI. In this example, we did both methods to

demonstrate. In this first DST function, we have: 1st Parameter: 0 (sl) – The first parameter is

responsible for the SLOT number. Slot 0 means that the stepper motor driver is connected

directly to the PLC. If a positioning expansion module is used and connected to the PLC, the

slot number will be the number corresponding to the number of modules connected to the

PLC. For example: If you have a PLC and three modules connected to its side and the

positioning module is the third module, the slot number in the DST function will be 3, and so

on. 2nd Parameter: D0000 (ax) – This parameter is responsible for the axis you want to move.

For the X axis, you must enter the value “0”. If you want to control the Y axis, the value of the

second parameter must be “1”. 3rd Parameter: D0005 (Target Position) – This parameter is

used to configure the position. It is the number of pulses that the PLC will send to the stepper

motor driver. The position will depend on how many degrees the stepper motor rotates with

one pulse. 4th Parameter: D0010 (Target Speed) – This parameter is responsible for the speed

of pulses per second sent by the PLC output. In this tutorial, the output we are using is P40.

The more pulses per second the PLC sends to the stepper motor driver, the faster the motor

will rotate. Respecting the limits of the stepper motor driver and the PLC. 5th Parameter:

D0015 (Dwell Time) – This parameter provides a time delay after the operation is performed.

It is most commonly used when using the table mentioned above (X-Axis Data), where you

configure a number of lines to perform a series of sequences. Then, when the program

finishes executing a line, it waits for a configured time, in milliseconds, in the Dwell Time and

only then starts the next line. If you leave this parameter at zero, the program will move on to

the next step without a time delay. 6th Parameter: D0020 (Mcode) – Always leave it at zero.

7th Parameter: D0025 (Control Word) – This parameter is responsible for defining the type of

coordinate you will use, Incremental or absolute, and is also responsible for the type of

control, Position or Speed, and we need to configure it through the 16 bits of a Word, where

we will use only bit 0 and bit 4:



Bit 0

Bit 4 

Position: 0

Absolute: 0

Speed: 1

Incremental: 1
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 Following the reasoning in the table above, we

have:
Type Position/ Absolute

Speed/ Incremental

Position/ Incremental

Absolute/ Speed

Binário

0000000000000000

0000000000010001

0000000000010000

0000000000000001 

Hexadecimal (h)

0

11

10

1 

The number entered in this parameter must be in hexadecimal.

The next DST function that is being triggered by memory M0004 has the function of sending

the motor back to the origin position (position 0). This origin position is the same position

when the FLT function was previously triggered, indicating where position 0 would be.

STP – Stop function, used to stop the motor from rotating. The first parameter refers to the

slot number, the second parameter to the axis (X = 0 / Y = 1) and the third parameter is the

deceleration time.

K0422 – Shows the current position of the X axis.



 

Full Schedule:
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And
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- Password to “open file” on the XG5000: - On the
XG5000: 1. Right-click on the project name and then
click on properties:
Password - XG5000 and PLC:

�



2. 

3. 

Enter the password, confirm and click OK:
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If the user needs to delete the password in the future, enter the password in the
“Previous
password” field and click delete as shown in the figure below:



1- 

- Password for the “PLC Program”:

To set a password for PLC programming, after connecting to the PLC, on the XG5000, click

on: Online > PLC Information > Password. Enter the password, confirm and click on

Change.
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Done, the password has now been transferred to the PLC. If the user wants to connect to the PLC

in the future

or wants to upload the program contained in it, the software will require the password.

To delete the password, follow step 3 on the previous page.



1- 

To perform this operation, the PLC does not need to be connected.
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If the user forgets the password that was set on the PLC, he/she has the option of clearing the
PLC parameters. Just remember that this command deletes all passwords, parameters and any
programs contained in it.

Click on Online > Clear All PLC > Yes:

Clearing all the PLC parameters:

And



 

2. Enter the password, confirm and click Apply:
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In XP-Builder:
1.Click on Project > Project Password:

Password for "opening the file or performing an upload
of the HMI" in XP-Builder:
Password - XP-Builder and HMI

�



4. 

 

Transfer the program to the HMI.
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Transfer the program to the HMI. Now, to open or perform an upload of the program, the

software will require the configured password.

 3. If in the future the user needs to delete the password, enter the password in the “Old

password” field and click on Delete, as shown in the figure below:

And
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In this example, we will enable only the X-axis, but if you wish to work with the second fast output,
enable the Y-axis in the same way.

Configuration in XG5000:
 Click on “Embedded Parameter” > “Position”:
PWM:



 

M00000 – Activates the PWM function.

D00000 – Total cycle period in milliseconds.

D00001 – Percentage of the “total cycle” in which the signal will be at a high logic level.
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In this example, we can conclude that the total cycle time is 10 seconds, and the output will

remain high logic level for 9 seconds and low logic level for 1 second.

Note: Whenever the time (D00000) or the percentage of the high logic level (D00001) is

changed, the program will require that memory M00000 be deactivated and reactivated to

update the change.

END.



 

6 – Click twice on P2P 01 > OK; 7- Click twice on P2P

Channel > In 2 Use > P2P Driver > Select: Modbus RTU

client:
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�

Reading Parameters on the Frequency Inverter:

In XG5000:

1.Click on Tools > Network Manager;

2.New > Choose a name > Select the PLC model;

3.Double-click on 00: Embedded Cnet;

4.Configure Channel 2x according to the RS485 serial data

(default baud rate: 9600) and in Channel 2, select: Use P2P;



8- Double click on P2P Block:
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9 - In index 0, configure:

Ch.: 2

P2P Function: Choose, Read (Ler) / Write (Escrever)

Conditional flag: M100 (for example) – In this field, you define which memory must be active

to start communication. Example of programming to automatically activate this memory.

The memories M100, M102, M103 correspond to the “Conditional Flag” of each line in the

P2P Block.
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Example: Depending on the PLC model, to configure the Frequency Command parameter,

you need to configure the Read area as h0005 minus 1: 0x30004, as shown in the figure

below:

Command Type: Continuous;

Data Type: Word;

Data Size: 2 – Number of words in sequence;

Destination station number: 1 – This is the address configured on the Inverter. If you are

working with more than one inverter, you can configure them in sequence: 1, 2, 3...

10 – Click on Setting:

Read area: In this field, you will find the address that needs to be configured according to

the specifications in the Inverter's manual:
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Save area: In this field, you must choose which memory the read data will be sent to. In this
example, we will choose memory D0.

 

Remember that earlier we selected Data size as 2, which means that 2 words will be reserved

in sequence. Since we chose D0000 to save the data from h0005, memory D0001 is also

reserved, which will store the data from h0006. If the data size had been configured to 3, we

could read the parameters h0005, h0006, h0007, and automatically save them in D0, D1, D2,

and so on.



 
Now, you need to click, still in XG-PD, on:

On line > Connect;

On line > Write Parameter;

On line > Enable Link (HS Link, P2P);

 Check the option P2P(EIP)01 and then click on Write:
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Inverter Manual.

Configure the P2P Block according to line 1 of the figure below:

O setting deve ser configurado da seguinte maneira: h0007 – 1: 0x40006 
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Figure:

 

Writing parameters to the Frequency Inverter:

Example to change the acceleration and deceleration edge parameters of the inverter via the HMI.
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In this way, the data from h0007, which corresponds to acceleration, will need to be written to

memory D3, and since the Data size was configured as 2, the data from h0008, which

corresponds to deceleration, should be written to memory D4. In the HMI programming, you

should create two Numeric Input fields and name them D3 and D4, respectively. When entering

data into D3 or D4, it will automatically be written to the inverter.

And. 



2- Click on Common > Project Property Settings
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�WRITING VALUES INTO THE FREQUENCY INVERTER:
1- Open XP-Builder and configure the HMI slave device as shown
in the screen below:
Modbus - RTU Communication: HMI with Frequency Inverter



 
3- 
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In the “XGT Panel Settings” tab we need to configure the communication medium (RS485) and the

communication speed of the HMI with the Inverter, which in this case will be configured for both

devices at 9600 bps:

4- After configuring the communication method between the HMI and the Inverter, we need to know
which parameters we will write and read in the Frequency Inverter. In this case, we are using an LS
inverter model IG5A, so below we will show a table that is contained in the inverter manual with the
addresses of its parameters.



In the LS inverter, select option number “7” within the “Frq” parameter.
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5- In this example, we will first write a value in the Inverter Frequency parameter. To do this,
we need to configure the frequency change method directly in the inverter. In the LS – IG5A
Inverter, we have the following options:



91 

6- In XP_Builder add a “Numeric Input” and configure it as shown in the screen
below:

Note that in the table presented above, the inverter memory that controls the frequency parameter is

0x0005. For this reason, we must enter the number “4” in the first field, which means “Write”, and in

the second field the memory designated for Writing 0005. Click OK.

 

Now that the inverter is configured to receive the frequency data from the HMI, we will create a

Numeric Input on the HMI that will send the value we enter to the memory responsible for the

frequency in the inverter.



Download the program and test.

Place 2 decimal places after the decimal point for the value to appear correctly
in the inverter.
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Reading Values from the Frequency Inverter:

 7. Now, we will create a Numeric Display on the HMI to read a parameter from the frequency

inverter. In this example, we will read the parameter that indicates the RPM value. According to the

table in the inverter manual, the memory corresponding to the RPM parameter is 0x0015. This

memory value is shown in hexadecimal in the manual, so we can convert it to decimal to input it into

the HMI. Converting “15H” to decimal gives the value “21”.

8- In the first field, enter the number “3” for “Reading” and in the second field, memory 21
corresponding to the RPM parameter in decimal and click OK.
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 STARTING, REVERSING AND STOPPING THE MOTOR:

9- To start and stop the inverter we must configure the inverter starting mode. In the

LS inverter the

DRV function must be changed to “3” according to the table below:
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10- Now let's check the specific bits for the “Forward Run”, “Reverse Run” and “Stop” functions that are
found in the same table seen previously:

We can see that bit 0 corresponds to Stop, bit 1 corresponds to Forward and bit 2 to Reverse.



11- In XP_Builder, create a “Word Switch” and configure the first field with the number
“4” as the HMI will write this bit to the slave and in the second field, according to the
table above, enter the Word “6”.

12- Now configure which bit of the Word you want to activate. First we want to activate
the STOP bit which according to the table is bit 0. To activate bit 0 of a Word we need to
write the number “1” in this Word. Example:
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The figure above shows that when we press the Stop button, the number 1 will be sent to
Word 0x006, activating bit 0 of this word.
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13- To create the “Forward Run” button, click “Word Switch” again and configure the

button as shown in the screen below:

The figure above shows that when we press the Forward Run button, the number 2 will be
sent to Word 0x006, activating bit 1 of this word.
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14- Finally, let's create the “Reverse Run” button. Click on “Word
Switch” again and configure it as shown in the screen below:
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The figure above shows that when we press the Reverse Run button, the number 4 will be sent to
Word 0x006, activating bit 2 of this word.



If communication between the inverter and the HMI is slow, configure “Wait to send”
as shown in the screen below:
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RS485 communication cable connection diagram
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And. 



In XP-Builder, click on Common > Project Property Setting:
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Password with levels in HMI

�



 

In the Security Settings tab, we can enter passwords according to the desired levels. In

Password input interval, we can enter the time that the password will remain active for the

user to make the necessary changes to the program. This means that if the user has entered

the password correctly, during these 3 minutes the password does not need to be entered

again.
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Enter the screen number for which you want the change to occur.

 To test this function, we will create a screen change button, but now with the passwords

already configured, the user will need to enter this password to move from one screen to

another.

Click on Change Screen Switch and create a button on the screen:
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Click on Extended and select the Security Level option and in Level define which Level will be

used for screen 2 of the program. In this case, we will leave level 1, which has the numerical

sequence 1, 2 and 3 as the password. It is in the Extended function that we find the option to

enter a password for all commands.
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To create a new screen, right-click on Base Screen and then click on Insert:

 

Configure the screen change button in the same way, but now to switch to screen 1
and with password level 2:
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We can simulate the program to confirm its operation:

 

When we click to change to screen two, the program will ask for the level 1 password (123)
and to return to screen 2, the program will ask for the level 2 password (345).
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And.



- Click Settings > Bus Parameters > check Baudrate (125Kbits/s) > click OK;
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DeviceNet Communication Tutorial
- Open SYCON > click on new;
- Select DeviceNet > ok;
- Click on Insert > Master;
- In Available masters select the device and click on Add > ok;
- Select the newly created master;
- Click on Setting > Master Setting > Setting > Check “Buffered, host
controlled” > ok > ok;
- Click on Setting > Device Assingment > click Connect COM 1,2... >
Check the desired COM
as shown in the screen below > ok:
DeviceNet Communication



- Select the Master and click Online > Download > Yes;

- On this same screen, click on Automatic Configuration > yes > ok;

- The screen will be as follows:

 

- Click Online > Automatic Network Scan. Wait for the screen to load and it will look like this:
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- Now open XGPD (in XG5000 > Tools > Network Manager);

- New > File name > Select PLC > Select PLC Model > ok;

- Click on Online > Connect;

- Click on Online > Read IO Information:

 

- Click on the High-speed Link tab > Double-click High-speed Link 01 > In Module Type select

Dnet > in Slot Number select the slot number where the Devinet module is located,

as shown in the screen below and click ok:
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- A table with several indexes will open, click once on Block and then click once on

0 in the first row as shown in the figure:
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- Now click on Online > Sycon Upload:

 

- The program will fill in index 0 automatically, you just need to fill in which memory will be

used to receive the data, in this case we address memory D0, as can be seen in the screen

below:
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- Click on Online > Write Parameter and check the option as shown in the screen below and

click ok:



 

- Click on Online > Reset > Reset Individual Module and select the option as shown in
the screen below, then click on OK:

 

- Click on Online > Enable Link and check the option as shown in the screen below and then
click on Write > Ok > Close:
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And
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- PLC; - Profibus communication module – XGL-PMEA; - Profibus device to be

communicated with;

To run a program to test communication:

- On the device to be communicated with, set the device address;

- Find the GSD file of the device to be communicated with;

- Copy and paste the GSD file into the root of the Sycon software (C: > LG Industrial

Systems > Sycon > Fildbus > Profibus > GSD);

- Connect a Female/Male RS232 cable between the PC and the Profibus Module

(XGL_PMEA);

- Open the Sycon software, create a new Profibus file;

- Insert a master, which in this case will be the PLC;

- Select the COM-C-DPM > Add>> OK option;

- Click on Settings > Master Settings and if it is not checked, check the Buffered, host

controlled option;

- Insert a slave below the master;

- Locate the GSD file in the list and add it;

- Click on Settings > Slave Configuration;

- Enter the address that was configured on the device to communicate in the

Station Address field and in the Append Module button, add the inputs and outputs

that

will be used;

- Close any program that is using the PC's COM port;

- Select the Mester0 device, go to Settings > Bus Parameter and select the

communication speed according to the PC's communication speed;

- Click Online > Download;

- Click on the Connect COM1 button and check the COM 1 field: on the left side > Ok >

Yes;

- The settings will be sent to the Profibus communication module;

Profibus Communication



 

- Create a new project in the XG5000 containing only one END in the program;

- In the XG5000, open the XG PD;

- Create a new file and connect;

- Click on Online > Read IO Information;

- Check the Slot number where the Pnet module is located

- Click on the High-speed Link tab > 2 clicks on High-speed Link 01;

- In Module type, select Pnet and in Slot Number, enter the number corresponding to the

slot

observed previously.

- Click anywhere in the gray table on the right;

- Click on online > Sycon Upload;

- In the gray table on the right, enter a memory address in Read area (e.g.:

D0) and an address in Save area (e.g.: D50);

- Click on Online > Write Parameter;

- Click on Online > Reset > Reset Individual Module;

- Select only the Pnet module to be reset;

- Click on Online > Enable Link and check only High-speed Link 01 > Write > Ok > Close;

The communication is now configured, to test you can send data from the device to

communicate, enter the XG5000 and in Monitor > Device Monitoring select memories D

to check if the data is arriving in memory D50 onwards, which is the memory responsible

for receiving data from the device to communicate as previously configured in the XG PD.

END.
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The parameter configuration table for the HIGH SPEED COUNTER function

is located in Embedded Parameter:

Encoder Configuration - HIGH SPEED COUNTER

On the XG5000:


